Jump to content
wind_kind

Petrol smell on engine start

Recommended Posts

wind_kind

Hey guys. I received my NC a couple of weeks ago and I'm having an absolute blast commuting with it. I recently noticed a strong petrol smell coming from the exhaust when I start it up so I assume it might be running a bit rich. Is there any adjustments I could make or is this something I'll need the dealer to take a look at?

Share this post


Link to post
trisaki

Hi are you opening the throttle on start up  , , turn key on wait for the buzzing etc to stop , hit starter ,no throttle  / 

Share this post


Link to post
wind_kind

I turn the key and give it a couple of seconds to go through its startup motions and don't touch the throttle when I start it.

  • Thanks 1

Share this post


Link to post
Iron horse

Welcome to the club! Been running my NC on the commute for the last few years - absolutely brilliant!

 

Does the rich exhaust smell go once warmed up? How is the fuel economy and general running of the bike? I got some water in the connector plug for the oxygen sensor on the exhaust after washing. It ran rich after that with a noticeable smell. The connector is on the right side of the bike near the horn. Might need to remove the lower cowl thing to get to it. Quick squirt of Wd and reconnected and all good now.

 

Has the bike has an air filter at some point, do you know?

  • Like 1

Share this post


Link to post
wind_kind
Posted (edited)

I don't really hang around long enough to tell if it goes away after a while. I'll do that tomorrow morning before work. As for the fuel economy, I'm not sure what I should expect. I do a 80 mile round trip each day and have to fill up at about the 200 mile mark when the fuel light starts blinking. Not sure how good or bad that is. I guess my riding style will influence that somewhat.

Edited by wind_kind

Share this post


Link to post
wind_kind
9 minutes ago, Iron horse said:

Has the bike has an air filter at some point, do you know?

I'm not sure.

Share this post


Link to post
Iron horse

200 at the low fuel warning is pretty good that's about 85 mpg. Sounds like not much wrong in that case. For me when the O² sensor wasn't working properly, there was a noticeable rich smell when stopping at the lights. Like how bikes used to smell, pre cat and all that

Share this post


Link to post
wind_kind

That is good to know. I'll see tomorrow morning if the smell persists after it's warmed up.

Share this post


Link to post
slowboy

Sounds normal to me, the engine managment system normally runs rich on a cold start then runs 'normally' once the engine's warmed up. If your getting 200 miles to a fill up, that sounds fine. 

  • Like 1

Share this post


Link to post
John Y

Whilst on the subject of fuel,  i am just getting used to the gauge etc. When the warning light comes on does anybody know roughly how many more miles could be achieved ? I always panic fill when i am down to a couple of bars.

 

 

Share this post


Link to post
Ciaran1602
11 minutes ago, John Y said:

Whilst on the subject of fuel,  i am just getting used to the gauge etc. When the warning light comes on does anybody know roughly how many more miles could be achieved ? I always panic fill when i am down to a couple of bars.

 

 

 

Not sure in terms of miles as it will vary on riding style but I believe the reserve is approx 3 litres. The dial on mine changes into a ‘litres consumed since warning light came on’ dial. I tend to fill up around the 2L consumed mark.

 

This is all from memory, I’ve not touched it since November.

Share this post


Link to post
neojynx
2 hours ago, John Y said:

Whilst on the subject of fuel,  i am just getting used to the gauge etc. When the warning light comes on does anybody know roughly how many more miles could be achieved ? I always panic fill when i am down to a couple of bars.

 

 

If you're lucky about 50 miles.

  • Like 1

Share this post


Link to post
John Y

That's useful cheers. I am never more than 5 or 6 miles from a garage on my commute so can afford to wait for the light i guess.

Share this post


Link to post
SteveThackery
3 hours ago, slowboy said:

Sounds normal to me, the engine managment system normally runs rich on a cold start then runs 'normally' once the engine's warmed up. If your getting 200 miles to a fill up, that sounds fine. 

 

I agree - this is completely normal.  Forget about it.

Share this post


Link to post
makman

Perfectly normal.  Runs rich until at correct temps and then evens the fueling out.  You are getting excellent MPG at that range of 200 miles for reserve. Better than my 700X.  With cold weather city riding it dips into the 56mpg range due to the short commute and cold weather.

Share this post


Link to post
embee

As the others say really.

When you do a cold start the mixture will be rich. The primary reason for this is that in engines with carbs or port fuel injection a significant amount of the fuel going in will condense out on the cold walls, resulting in less fuel available for combustion. Since it will only burn successfully within a certain range of air/fuel mixture ratio it is necessary to have a bit more fuel than normal to compensate for the condensed fuel to get it to fire up. Also it is generally much easier to ignite a mixture of fuel in vapour/gas form rather than liquid, and when cold only very small amounts of the fuel will evaporate during the first few cycles, again needing a bit extra to be put in to get enough volatile parts released. This is why winter fuels have a higher volatility than summer fuels (measured on the Reid Vapour Pressure RVP scale).

As soon as the engine fires and begins to warm, parts of this extra fuel on the walls will start to come away with the intake air, so the enrichment can be ramped down very quickly. An injection engine will have a "cranking fuel" calibration which will apply while the starter is cranking, then an "afterstart fuel" calibration which might ramp off in perhaps 10sec, then it will run on a mapped value in open-loop until the exhaust oxygen (lambda) sensor is hot enough (circa 300C) to start working at which point it will switch to feedback control of the fuelling (closed loop). The catalyst itself will take a bit longer to get hot enough to start reacting significantly, maybe a minute or so, and hydrocarbon fuel will get through without being reacted. Cars these days have electrically heated lambda sensors to get them working sooner, the NC sensor is not heated (2 wire type) but will start working within a minute or so typically.

In the first few seconds of running some hydrocarbon fuel will get through the engine without being burnt, and will mix with condensation (water) in the exhaust gas and be carried out the tailpipe as white vapour. The first few seconds of vapour will smell of petrol to some extent, then the smell should reduce/disappear but the white condensed water vapour will persist until the exhaust system warms enough to keep it gas and invisible. The most white vapour is noticeable a short while after starting because at first it condenses and accumulates inside the cold exhaust and then starts to be driven off again as it warms, so you get a peak in white condensation after a few tens of seconds, 30sec maybe.

Enrichment shouldn't be confused with raised cold idle speed, the speed will take longer to ramp down because the engine needs to be a little warmer in order for the combustion to be properly stable so it is held higher to improve driveability and avoid stalling, but after 20 or 30sec the engine should be running more or less stoichiometric fuelling (essential to meet emission regulations).

  • Like 6

Share this post


Link to post
rjp996

once the light comes on, on mine it starts to monitor the fuel being used and starts from zero counting up - reserve is 3.5 liters, and ive run mine to 3/3.1 liters on many an occasion - adds to the excitement of the commute ;-). If im at work and the light just came on I can make the 50 mile trip back home on reserve, so long as don't thrash it, stay under 70

  • Haha 1

Share this post


Link to post
wind_kind
On 03/01/2019 at 11:54, makman said:

Perfectly normal.  Runs rich until at correct temps and then evens the fueling out.  You are getting excellent MPG at that range of 200 miles for reserve. Better than my 700X.  With cold weather city riding it dips into the 56mpg range due to the short commute and cold weather.

I did notice that the smell goes away after riding a bit so no worries there any longer. I was wrong in that 200 miles estimation. That was during very calm after Christmas London traffic and I only fueled up twice. Now that it's all back to normal my mileage has gone down considerably. I do about 155 miles now but I'm tracking it properly now, so will see after a month or so.

  • Like 1

Share this post


Link to post
Scootabout

My NC700X has a reserve of about 3 litres. If I see it come on I'll allow about 25 miles of town riding before filling up, or 35-40 miles of open road riding. If I didn't see the bar start to flash, I'll be more conservative. My aim is to have at least a litre left when I fill up. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×