Jump to content
sams700

Oxford heated grip controller issue

Recommended Posts

sams700

Has anyone else had an issue with their heated grips controller.

 

Mine packed up after a couple of months.  It's just goes into battery saving mode despite the bike running!

Share this post


Link to post
Radarman

From Oxford heated grips manual:

 

Quote

The controller goes into Battery Saving Mode after 5 seconds of the voltage being less than 11.5V, or after 2 minutes of not detecting any noise on the 12V power lead. Once in this mode, it will wait a further 5 minutes or thereabouts before switching off completely.

 

I would check your bike battery voltages first (should be something like 12.7V when removed from bike) and while on idle it should be around 13.7 - 13.9V. If voltages are OK only then I would consider Oxford controller faulty.

Share this post


Link to post
sams700

Thanks but it didn't work when the bike was running at 70 mph and it should be charging fine it's a newish bike

Share this post


Link to post
Mister Paul
5 hours ago, sams700 said:

Has anyone else had an issue with their heated grips controller.

 

Mine packed up after a couple of months.  It's just goes into battery saving mode despite the bike running!

It will be under warranty. Get in touch with the seller. 

Share this post


Link to post
Old Badger

I had a similar issue years ago , it was a loose connector from the controller to the grip  

Share this post


Link to post
sams700

I tried all the connectors as they are push fit and no joy.  New controller on.the way!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×